Impossible de continuer l'installation

Tout ce qui est en rapport avec l'installation de Ydle
Arnoaud
Messages : 3
Inscription : 01 Juin 2016, 18:57

Impossible de continuer l'installation

Messagepar Arnoaud » 01 Juin 2016, 19:14

Bonjour à tous,
Je viens de découvrir ce projet qui m'a l'air vraiment fun ! Mais voilà ... je me suis lancé dans l'installation mais impossible de continuer une fois arrivé à cette étape : http://wiki.ydle.fr/doku.php?id=ydle:in ... 04-symfony

Je renseigne les informations pour l'installation (j'ai mis les mêmes que celles sur le wiki) :

Code : Tout sélectionner

--------------------
Application path : /var/www/
Application directory : ydle/
--------------------
Ydle Database :
Database host : 127.0.0.1
User : ydle
Password : raspberry
Database name : ydle
--------------------
HUB UI
User : Dormeur
Password : 123456
E-Mail : **********
--------------------
All the parameters are ok ? (Y/n)Y


Je crée la database :

Code : Tout sélectionner

Do you want to create database ? [y/n]y
Root password for mysql:
root
CREATE DATABASE ydle DEFAULT CHARACTER SET utf8 DEFAULT COLLATE utf8_general_ci;
    CREATE USER 'ydle'@'localhost' IDENTIFIED BY 'raspberry';
    GRANT ALL ON ydle.* TO 'ydle';
    quit;
All settings correct for using Composer
Downloading 1.1.2...

Composer successfully installed to: /var/www/composer.phar
Use it: php composer.phar
Running composer as root/super user is highly discouraged as packages, plugins and scripts cannot always be trusted
Installing ydle/framework (dev-master 3acf07e0e26e16063999b3e244c913df7bcd6a83)
  - Installing ydle/framework (dev-master master)
    Cloning master

Created project in ydle//
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
  - Installing behat/transliterator (v1.0.1)
    Downloading: 100%

  - Installing doctrine/lexer (v1.0.1)
    Downloading: 100%

  - Installing doctrine/annotations (v1.2.3)
    Downloading: 100%

  - Installing twig/twig (v1.18.0)
    Downloading: 100%

  - Installing psr/log (1.0.0)
    Downloading: 100%

  - Installing doctrine/inflector (v1.0.1)
    Downloading: 100%

  - Installing doctrine/collections (v1.2)
    Downloading: 100%

  - Installing doctrine/cache (v1.4.0)
    Downloading: 100%

  - Installing doctrine/common (v2.4.2)
    Downloading: 100%

  - Installing symfony/symfony (v2.6.3)
    Downloading: 100%

  - Installing jdorn/sql-formatter (v1.2.17)
    Downloading: 100%

  - Installing doctrine/doctrine-cache-bundle (v1.0.1)
    Downloading: 100%

  - Installing doctrine/dbal (v2.5.1)
    Downloading: 100%

  - Installing doctrine/doctrine-bundle (dev-master 698b10b)
    Cloning 698b10bb523a8e744184382bb478376f5197e59f

  - Installing doctrine/orm (v2.4.7)
    Downloading: 100%

  - Installing willdurand/negotiation (1.3.4)
    Downloading: 100%

  - Installing willdurand/jsonp-callback-validator (v1.1.0)
    Downloading: 100%

  - Installing friendsofsymfony/rest-bundle (1.3.1)
    Downloading: 100%

  - Installing friendsofsymfony/user-bundle (dev-master f54031a)
    Cloning f54031a652846cd8e7b12119fe713eae90e24cf9

  - Installing incenteev/composer-parameter-handler (v2.1.0)
    Downloading: 100%

  - Installing jms/metadata (1.5.1)
    Downloading: 100%

  - Installing phpoption/phpoption (1.4.0)
    Downloading: 100%

  - Installing jms/parser-lib (1.0.0)
    Downloading: 100%

  - Installing phpcollection/phpcollection (0.4.0)
    Downloading: 100%

  - Installing jms/serializer (0.16.0)
    Downloading: 100%

  - Installing jms/serializer-bundle (dev-master 8bce2e8)
    Cloning 8bce2e83779ebdf70116018e68d8d9f930bbe124

  - Installing nikic/php-parser (v0.9.4)
    Downloading: 100%

  - Installing jms/translation-bundle (dev-master 8eff567)
    Cloning 8eff56746b73762dfe06414faf0fb609bfe51754

  - Installing knplabs/knp-menu (v2.0.1)
    Downloading: 100%

  - Installing knplabs/knp-menu-bundle (v2.0.0)
    Downloading: 100%

  - Installing knplabs/knp-components (1.3.1)
    Downloading: 100%

  - Installing knplabs/knp-paginator-bundle (dev-master b51aa32)
    Cloning b51aa32f129711fa76f853b7536efefd8c5dbf07

  - Installing sensiolabs/security-checker (v2.0.1)
    Downloading: 100%

  - Installing sensio/distribution-bundle (v3.0.15)
    Downloading: 100%

  - Installing sensio/framework-extra-bundle (v3.0.4)
    Downloading: 100%

  - Installing sensio/generator-bundle (v2.5.1)
    Downloading: 100%

  - Installing cocur/slugify (v1.0)
    Downloading: 100%

  - Installing sonata-project/core-bundle (dev-master 5d1e71c)
    Cloning 5d1e71c46b892c4e3cc5161a2c48ab46c8c07203

  - Installing sonata-project/datagrid-bundle (dev-master dba166c)
    Cloning dba166c6c52591f1bfafa8514b848a3bae23a557

  - Installing gedmo/doctrine-extensions (v2.3.11)
    Downloading: 100%

  - Installing stof/doctrine-extensions-bundle (dev-master 2ff8473)
    Cloning 2ff8473e33e224af87dc00d48a552a35a75115af

  - Installing kriswallsmith/assetic (v1.2.1)
    Downloading: 100%

  - Installing symfony/assetic-bundle (v2.6.1)
    Downloading: 100%

  - Installing monolog/monolog (1.12.0)
    Downloading: 100%

  - Installing symfony/monolog-bundle (v2.7.1)
    Downloading: 100%

  - Installing swiftmailer/swiftmailer (v5.3.1)
    Downloading: 100%

  - Installing symfony/swiftmailer-bundle (v2.3.8)
    Downloading: 100%

  - Installing twig/extensions (v1.2.0)
    Downloading: 100%

  - Installing ydle/hub-bundle (0.5.92)
    Downloading: 100%

  - Installing doctrine/data-fixtures (v1.0.0)
    Downloading: 100%

  - Installing doctrine/doctrine-fixtures-bundle (dev-master c5ff054)
    Cloning c5ff0542772102ddd4e2fbe173e9ad40ad67c22f

friendsofsymfony/user-bundle suggests installing willdurand/propel-typehintable-behavior (Needed when using the propel implementation)
jms/serializer-bundle suggests installing jms/di-extra-bundle (Required to get lazy loading (de)serialization visitors, ~1.3)
knplabs/knp-menu suggests installing pimple/pimple (for the built-in implementations of the menu provider and renderer provider)
knplabs/knp-menu suggests installing silex/silex (for the integration with your silex application)
knplabs/knp-components suggests installing doctrine/mongodb-odm (to allow usage pagination with Doctrine ODM MongoDB)
knplabs/knp-components suggests installing propel/propel1 (to allow usage pagination with Propel ORM)
knplabs/knp-components suggests installing ruflin/Elastica (to allow usage pagination with ElasticSearch Client)
knplabs/knp-components suggests installing solarium/solarium (to allow usage pagination with Solarium Client)
gedmo/doctrine-extensions suggests installing doctrine/mongodb-odm (to use the extensions with the MongoDB ODM)
stof/doctrine-extensions-bundle suggests installing doctrine/mongodb-odm-bundle (to use the MongoDB ODM extensions)
kriswallsmith/assetic suggests installing leafo/lessphp (Assetic provides the integration with the lessphp LESS compiler)
kriswallsmith/assetic suggests installing leafo/scssphp (Assetic provides the integration with the scssphp SCSS compiler)
kriswallsmith/assetic suggests installing leafo/scssphp-compass (Assetic provides the integration with the SCSS compass plugin)
kriswallsmith/assetic suggests installing patchwork/jsqueeze (Assetic provides the integration with the JSqueeze JavaScript compressor)
kriswallsmith/assetic suggests installing ptachoire/cssembed (Assetic provides the integration with phpcssembed to embed data uris)
symfony/assetic-bundle suggests installing kriswallsmith/spork (to be able to dump assets in parallel)
monolog/monolog suggests installing aws/aws-sdk-php (Allow sending log messages to AWS services like DynamoDB)
monolog/monolog suggests installing doctrine/couchdb (Allow sending log messages to a CouchDB server)
monolog/monolog suggests installing ext-amqp (Allow sending log messages to an AMQP server (1.0+ required))
monolog/monolog suggests installing ext-mongo (Allow sending log messages to a MongoDB server)
monolog/monolog suggests installing graylog2/gelf-php (Allow sending log messages to a GrayLog2 server)
monolog/monolog suggests installing raven/raven (Allow sending log messages to a Sentry server)
monolog/monolog suggests installing rollbar/rollbar (Allow sending log messages to Rollbar)
monolog/monolog suggests installing ruflin/elastica (Allow sending log messages to an Elastic Search server)
monolog/monolog suggests installing videlalvaro/php-amqplib (Allow sending log messages to an AMQP server using php-amqplib)
doctrine/data-fixtures suggests installing doctrine/mongodb-odm (For loading MongoDB ODM fixtures)
doctrine/data-fixtures suggests installing doctrine/phpcr-odm (For loading PHPCR ODM fixtures)
Generating autoload files
> Incenteev\ParameterHandler\ScriptHandler::buildParameters
Creating the "app/config/parameters.yml" file
Some parameters are missing. Please provide them.
master_address ('http://127.0.0.1'): 127.0.0.1
Deprecation Notice: The callback Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::buildBootstrap declared at /var/www/ydle/vendor/sensio/distribution-bundle/Sensio/Bundle/DistributionBundle/Composer/ScriptHandler.php accepts a Composer\Script\CommandEvent but post-install-cmd events use a Composer\Script\Event instance. Please adjust your type hint accordingly, see https://getcomposer.org/doc/articles/scripts.md#event-classes in phar:///var/www/composer.phar/src/Composer/EventDispatcher/EventDispatcher.php:289
> Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::buildBootstrap
Deprecation Notice: The callback Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::clearCache declared at /var/www/ydle/vendor/sensio/distribution-bundle/Sensio/Bundle/DistributionBundle/Composer/ScriptHandler.php accepts a Composer\Script\CommandEvent but post-install-cmd events use a Composer\Script\Event instance. Please adjust your type hint accordingly, see https://getcomposer.org/doc/articles/scripts.md#event-classes in phar:///var/www/composer.phar/src/Composer/EventDispatcher/EventDispatcher.php:289
> Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::clearCache
Clearing the cache for the dev environment with debug true
Deprecation Notice: The callback Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::installAssets declared at /var/www/ydle/vendor/sensio/distribution-bundle/Sensio/Bundle/DistributionBundle/Composer/ScriptHandler.php accepts a Composer\Script\CommandEvent but post-install-cmd events use a Composer\Script\Event instance. Please adjust your type hint accordingly, see https://getcomposer.org/doc/articles/scripts.md#event-classes in phar:///var/www/composer.phar/src/Composer/EventDispatcher/EventDispatcher.php:289
> Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::installAssets
Installing assets as hard copies.
Installing assets for Symfony\Bundle\FrameworkBundle into web/bundles/framework
Installing assets for JMS\TranslationBundle into web/bundles/jmstranslation
Installing assets for Ydle\HubBundle into web/bundles/ydlehub
Installing assets for Sonata\CoreBundle into web/bundles/sonatacore
Installing assets for Sensio\Bundle\DistributionBundle into web/bundles/sensiodistribution
Deprecation Notice: The callback Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::installRequirementsFile declared at /var/www/ydle/vendor/sensio/distribution-bundle/Sensio/Bundle/DistributionBundle/Composer/ScriptHandler.php accepts a Composer\Script\CommandEvent but post-install-cmd events use a Composer\Script\Event instance. Please adjust your type hint accordingly, see https://getcomposer.org/doc/articles/scripts.md#event-classes in phar:///var/www/composer.phar/src/Composer/EventDispatcher/EventDispatcher.php:289
> Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::installRequirementsFile
Do you want to remove the existing VCS (.git, .svn..) history? [Y,n]? Y
Updating database schema...
Database schema updated successfully! "16" queries were executed
Careful, database will be purged. Do you want to continue Y/N ?Y
  > purging database
  > loading Ydle\HubBundle\DataFixtures\ORM\LoadRoomData
  > loading Ydle\Bundle\DataFixtures\ORM\LoadData
  > loading Ydle\HubBundle\DataFixtures\ORM\LoadNodesData
Created user Dormeur
pi@raspberrypi:/var/www $


Mais voilà... ça commence à bloquer à cet endroit ci :
On me dit que master_address n'est pas valide (ou ne convient pas?).
Et que d'autres paramètres sont incorrects.

Code : Tout sélectionner

Generating autoload files
> Incenteev\ParameterHandler\ScriptHandler::buildParameters
Creating the "app/config/parameters.yml" file
Some parameters are missing. Please provide them.
master_address ('http://127.0.0.1'): 127.0.0.1


S'en vient ensuite des messages comme celui là :

Code : Tout sélectionner

Deprecation Notice: The callback Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::installRequirementsFile declared at /var/www/ydle/vendor/sensio/distribution-bundle/Sensio/Bundle/DistributionBundle/Composer/ScriptHandler.php accepts a Composer\Script\CommandEvent but post-install-cmd events use a Composer\Script\Event instance. Please adjust your type hint accordingly, see https://getcomposer.org/doc/articles/scripts.md#event-classes in phar:///var/www/composer.phar/src/Composer/EventDispatcher/EventDispatcher.php:289


Ensuite j'essaye d'accéder à la page via un ordinateur en tapant l'adresse IP de ma Raspberry (192.168.0.47) mais Chrome m'averti que :

Code : Tout sélectionner

Ce site est inaccessible
192.168.0.47 n'autorise pas la connexion.
Essayez les suggestions ci-dessous :
Recharger la page
Vérifier la connexion
Vérifier le proxy et le pare-feu
ERR_CONNECTION_REFUSED


Et de même lorsque j'essaye d'y accéder par le navigateur de ma Raspberry en tapant directement 127.0.0.1, ça ne fonctionne pas.

Si quelqu'un de très sympa (OUI! Je suis sûr qu'il n'y a que des gens sympas ici !) pouvait m'aiguiller dans ma galère :D
Pour info j'utilise une Raspberry Pi 2 avec une Micro SD de 32Go

Meeeeeeeerci bien :)
Pièces jointes
chrome.PNG
Google Chrome
chrome.PNG (15.28 Kio) Consulté 8903 fois
marche pas.PNG
Etapes de l'installation
marche pas.PNG (93.59 Kio) Consulté 8903 fois

Avatar de l’utilisateur
Yaug
Administrateur
Messages : 1466
Inscription : 19 Juillet 2013, 17:09
Localisation : Moselle
Contact :

Re: Impossible de continuer l'installation

Messagepar Yaug » 03 Juin 2016, 13:35

Bonjour
Les "deprecated calls" sont normal. Ce ne sont pas des erreurs mais des rappels qu'il faut changer de version de symfony.
Mais merci de me les avoir remonté.

Concernant l'impossibilité de te connecter, là, cela veut dire que ton serveur web n'est pas fonctionnel.
Et c'est ce qu'il faut corriger.
Que te donnes les logs pour le serveur web ?

Arnoaud
Messages : 3
Inscription : 01 Juin 2016, 18:57

Re: Impossible de continuer l'installation

Messagepar Arnoaud » 04 Juin 2016, 16:14

Pour Symfony je dois faire comment du coups ? Je dois faire un "sudo apt-get upgrade" ?

Comment je fais pour accéder aux logs ?

Avatar de l’utilisateur
Yaug
Administrateur
Messages : 1466
Inscription : 19 Juillet 2013, 17:09
Localisation : Moselle
Contact :

Re: Impossible de continuer l'installation

Messagepar Yaug » 04 Juin 2016, 22:02

Pour symfony, rien de grave, tu peux les laisser, il faut que je fasse la mise à jour de mon côté.

Pour les logs, ils sont dans /var/log normalement.

nginx est démarré ?

Arnoaud
Messages : 3
Inscription : 01 Juin 2016, 18:57

Re: Impossible de continuer l'installation

Messagepar Arnoaud » 08 Juin 2016, 15:43

Ngix est démarré ... je pense ...
Dans /var/log/ il y a pleins de fichiers, je te transfère le quel ?

Avant de télécharger ton script d'installation, j'ai essayé d'accéder à l'adresse IP de la Raspberry, est c'est marqué "File not found"
filenotfound.PNG
File not found
filenotfound.PNG (8.84 Kio) Consulté 8874 fois

Avatar de l’utilisateur
Yaug
Administrateur
Messages : 1466
Inscription : 19 Juillet 2013, 17:09
Localisation : Moselle
Contact :

Re: Impossible de continuer l'installation

Messagepar Yaug » 08 Juin 2016, 21:29

Hum....
Bizarre tout ça.

tu devrais faire un tail -f /var/log/fichiererreur.log pendant que tu affiches la pages

fichier erreur étant un des fichiers présents.
Au pire copie moi la liste des fichiers que je t'indique dans lequel regarder


Revenir vers « Installation »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 0 invité

cron